FANDOM


Ok this whole time when I been loading sprites I been removing the little thing in front of the directory file for example


lsp 700,":a;chara\sylph_st21r.bmp",251,190

basically if I break it down

lsp  ----is a function that tells the game to load up a sprite

700 ----- is the sprite number

":a;chara\sylph_st21r.bmp" -----is the file directory (AT THE TIME I ASSUMED ":a;" WAS THE ARC OR SOMETHING >.> )

251 is the location of the sprite far as X is concerned (the origin or the 0 for X being at the left most end with positive numbers moving it to the right)

190 is the same as above but for Y (and oddly enough 0 is not at the bottom but instead at the top with positive numbers going down.....)


Since I always assumed :a; was the way the game told it to look inside the NSA files and the arcs I always removed them for custom images like the example below

lsp 700,"2.5\mob_heinrich1.bmp",0,0

and did they show up fine? Yeah look at my mod and tell me if they ever bugged out (when I properly cleaned them up...)


If you been following my mod I recently took out new attacks for salamander so I wanted to use the salamander image Alraune had given me permission to use. I know the spirits show up with that ghost-like effect with the function *syoukan_effect

so I look at for example sylph...

lsp2 0,":a;chara\sylph_st01.bmp",250,300,100,100,0,200
gosub *syoukan_effect


LSP2 is a whole different animal I had to figure out so I would know what all those numbers did. after like 5 hours of breaking my head looking at this section of the code until I figured it out lol....

LSP2 has its own function since its not built into the game (i might be wrong cause I never actually bothered looking for LSP since LSP is already in the reference... [Reference to all commands already built in (I believe anyways)]

So I found LSP2 and I find this....

lsp2 %sub2,$sub1,%sub4,%sub5,%sub6,%sub7,%sub10 : print %50,%51

now what the hell is all of this? well I look above and I get this mess...

    atoi %sub2,$sub2 : add %sub2,246    ;ƒXƒvƒ‰ƒCƒg”ԍ†i246`255j
    atoi %sub4,$sub4    ;’†S‚wÀ•W
    atoi %sub5,$sub5    ;’†S‚xÀ•W
    atoi %sub6,$sub6: add %sub6,100    ;‚wŠg‘å—¦
    atoi %sub7,$sub7: add %sub7,100    ;‚xŠg‘å—¦
    atoi %sub10,$sub10    ;‰ñ“]Šp
    atoi %50,$50    ;ƒGƒtƒFƒNƒg
    atoi %51,$51    ;ƒvƒŠƒ“ƒgŽžŠÔ

so I spend 5 hours here breaking my head trying to figure out  what all those non-sensical comments are (the comments are everything past the semi-colon)

until it fucking hits me....covariant had told me originally on my talk-blog about the encoding. so...I copy that section of that code to a new tab and then re-encode it with Japanese character and BAM i get fucking Kanji \o/

after that it was only a matter of getting them to google translate to figure out what they meant

so OK!!! Now I know how to load up mandy (alraune's salamander) into the the fight with the use of syoukan no?

lsp2 0,"2.5\salamander2_st02.bmp",200,300,100,100,0,200


AHAHAHAHAHA....no >.>;

If you played patch 1.4B you saw three bugs. Alraune was having green pixel distortions in the story section.

Normally when I have these I go to GIMP since I got years of experience using it and I fix them by hand.

however here I did the same thing and I still had some green. OK so if I have green there I should have green on the fight as well no since its the same sprite?

wrong....but HOW? its the same sprite so they should both have the same problem or neither! (I'll get to this later...)

One bug was with mandy being too low when she showed up alongside Luka and Salamander (that was a positioning error of mine so whatever skip that one...)

The third bug was when you used Passionate Wrath Mandy would come out with her ugly ass white-background (the other half of the image that the game uses for transparency or something I don't know really....I don't know much on CG art...)

so what the hell? why am I getting it here I mean I look at the code and sylph (same with gnome, undine and salamander) is written the same way as Mandy no?


lsp2 0,":a;chara\sylph_st01.bmp",250,300,100,100,0,200
lsp2 0,"2.5\salamander2_st02.bmp",200,300,100,100,0,200

Yeah they are the same (ok well here the first number (250 and 200 have to do with positioning but other than that...)

no different aside from the fact the directories are elsewhere. sylph is inside the arc files in chara no? and mandy is in the 2.5 folder

after like an hour of breaking my head I'm like

"You know what fuck this! "

and instead of

lsp2 0,"\salamander2_st02.bmp",200,300,100,100,0,200

I decide to type down...

lsp2 0,":a;2.5\salamander2_st02.bmp",200,300,100,100,0,200

JUST to see what would happen don't care at the moment if it crashes or not since it won't find the file in the nsa files so its a dud or w/e you want to call it

I save it the script...package it and move it to the game folder and...

BAM fixed

>.o what!?

but doesn't the ":a;" mean its looking through the arc files or something

apperently not

so now I go back to the alraune and just for the hell of it I do the same thing and I put :a; in front of it just to see what happens

BAM also fixed

WTF!!!

but why should alraune be fixed like that when in the battle she doesn't have that right!?

I go back to my change on the script (refer to one of the other blogs)

[To summarize that other blog post : the game has a variable called mon_labo_on which if 0 means its part of the game (inside the story or the encyclopedia but if it is 1 then it knows it is running a side story and will instead look for the sprites inside of the folder specified or whatever (never done a side story TBH) so I added a third number....If mon_labo_on = 2 then instead it will look inside MY folder and thus allow me to use my art ]

so I look at my code...(or just a small section since the mon_labo_on=2 is actually in like 6 different and spread out sections of the game's code)


*syutugen2

saveoff
if %music<>%nowmusic gosub *musicplay

if %mon_labo_on=0 || %mon_labo_on=2 mov $ori_name,"Luka":mov %player,0:skip 3
if %mon_labo_on=1 && $ori_name="" mov $ori_name,"Luka":mov %player,0:skip 2
if %mon_labo_on=1 && $ori_name<>"" mov %player,99

gosub *setwindow_02
cspl 592,595
if %mon_labo_on=2 lsp 700,":a;2.5\"+$tatie1+".bmp",%monster_x,%monster_y:skip 3
if %mon_labo_on=1 && %chara_ori=1 lsp 700,":a;"+$mon_labo_mon_folder+"\"+$tatie1,%monster_x,%monster_y:skip 2
lsp 700,":a;chara\"+$tatie1+".bmp",%monster_x,%monster_y

don't see anything? Let me make it bold and underline then.....

gosub *setwindow_02
cspl 592,595
if %mon_labo_on=2 lsp 700,":a;2.5\"+$tatie1+".bmp",%monster_x,%monster_y:skip 3
if %mon_labo_on=1 && %chara_ori=1 lsp 700,":a;"+$mon_labo_mon_folder+"\"+$tatie1,%monster_x,%monster_y:skip 2
lsp 700,":a;chara\"+$tatie1+".bmp",%monster_x,%monster_y


the game is loading my custom monster files as

lsp 700,":a;2.5\[filename].bmp" etc. etc.

so my alraune right before the fight is....

lsp 700,"2.5\alraune_st01.bmp",0,0:print 10,500

but when the fight loads up and does the process to check for custom monsters it changes the loading sprite into...

lsp 700,":a;2.5\alraune_st01.bmp",0,0:print 10,500


WHAT THE HELL IS :a; (and for that matter :c; since it is used in another effect which I forgot at the moment [I think its for the small skill slabs I got amnesia at the moment....)

I got NO idea but does it matter!?

apperently so >.>

/end of rant lol

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.